Problemas para añadir items; No los veo en el partida

    Comparte
    avatar
    elgranselda
    Espadachín
    Espadachín

    Mensajes : 276

    Problemas para añadir items; No los veo en el partida

    Mensaje por elgranselda el Jue Nov 07, 2013 1:51 am

    Tengo un problema sobre los items cuando trato de añadirlos no me aparecen. estos son los paso que hago. Primeramente para no equivocarme llamare al mod que quiero añadirle el item mod1, y al otro mod2 el que me suplira el item.

    Abro el OpenBrf y busco el archivo Brf. en donde encontrare mi item deseado, en este caso un casco. el archivo se llama modhelmets.brf se encuentra en la carpeta de resource del  mod2.




    encontrado mi item copio modhelmets.brf y lo pego dentro de la carpeta Resource del mod1, paso a la carpeta de texturas del mod2 copio el archivo textura de mi casco o item que elegí y lo pego en la carpeta de textura del mod1. Entiendo que cada textura tiene el mismo nombre que su Brf. o item, en mi caso el casco se llama helmet_chalcidean_black_2 en resource y en textura.  paso abrir el programa Morgh´s, ubico el module directory a la dirección del mod1



    elijo la opción correspondiente




    tomo un item cualquiera y hago click en update


    luego aparece una ventana emergente y acepto


    paso hacer lo siguiente


    1:copie y pegue el nombre de mi casco
    2:modifique los atributos mas armadura y mas abundancia
    3:update



    luego de aceptar click a update&save changes, saldrá una ventana emergente que dirá que nuestro item fue añadido


    luego click en save change y eso fue todo


    aquí aparece añadido


    Por ultimo quiero decir que en los atributos aumento la abundancia porque creo que así puedo encontrarlo casco rápido, pero no lo encuentro. busco y busco y nada, creo una partida nueva y aun no me aparece Neutral


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]




    La verdad nos hara libres study
    avatar
    Hijodeleon
    Brytenwalda
    Brytenwalda

    Mensajes : 1812
    Facción : Caballerosdecalradia.net

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Hijodeleon el Jue Nov 07, 2013 2:10 am

    claro porque te faltan dos pasos.
    luego que haces todo eso vas al module.ini del mod1 y le das editar.
    luego debajo de las lineas load_module_resource copias una igual o la escribes y le pegas el nombre del brf y guardas. Luego vas al item_kind1 del mod2 y copias todo lo referente al nombre de ese item y vas al item_kind1 del mod uno l le das editar y debajo de todo le das pegar.

    Si no me explique bien, mira este tuto del buen Neodrako que me hizo personalmente Jaja Cool 

    [Tienes que estar registrado y conectado para ver este vínculo]
    buscalo en una de las hojas en esta a pag.


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]
    Conoce las características de este SuperMod, tocando en la imagen de mi firma.



    ..por medio de laborar así tienen que prestar ayuda a los que son débiles, y tienen que tener presentes las palabras del Señor Jesús, cuando él mismo dijo: ‘Hay más felicidad en dar que en recibir’”.


    Lucas: Roma: 33–c. 61 e.c.
    avatar
    Gerik
    Moderador
    Moderador

    : : Alone Wolf
    Mensajes : 1109
    Edad : 21
    Facción : Reino del Norte

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Gerik el Jue Nov 07, 2013 2:11 am

    Muevo tema.
    Ya es el segundo tema que haces en su zona incorrecta, te pido que tengas más cuidado.




    _________________

    [Tienes que estar registrado y conectado para ver este vínculo]
    [Tienes que estar registrado y conectado para ver este vínculo]
    [Tienes que estar registrado y conectado para ver este vínculo]

    avatar
    Neodrako
    Usuario VIP
    Usuario VIP

    Mensajes : 4408
    Edad : 34
    Facción : Gran Polonia

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Neodrako el Jue Nov 07, 2013 2:25 am

    Es que te faltan 2 cosas. pero yo te voy a indicar una tercera.

    Primero que nada vete a la carpeta del mod y busca un archivo llamado module ini. habrelo con notepad ++ y busca en el una línea llamada load_module_resource = materials_face_gen



    En la imagen indico con una flecha roja esa línea que tienes que buscar y debajo pegas esto

    load_mod_resource = y el nombre del brf.

    si te fijas yo tengo puestos 2 y uno lo señale con una flecha azul.

    esto es importante para que el juego cargue ese recurso.

    Bueno contiunamos ahora vete al archivo item_kinds del mod del que estas sacando ese ítem y en la pestaña llamada buscar pon el mismo nombre que tiene ese carco en el brf y te llevara a la línea donde esta y veras algo a si pero con el nombre de tu casco.



    copias la línea entera y vete al mismo archivo pero del mod al que quiere llevar ese ítem.

    pega esa línea al final del archivo. pero ojo tiene que quedar como estaba en su archivo de origen o dara error.

    bien ahora sube a la parte superior del archivo y veras el numero de ítems del archivo.

    imagina que son 3256 pues como añadites uno modifica el ultimo numero añadiéndole 1 seria asi 3257.

    bueno cierra y vete al Morghs a el editor de items y si lo hiciste bien ahora veras ese casco al final de la lista de ítems y puedes modificarlo a tu gusto.





    _________________
    Prefiero vivir un dia como lechón que 100 años como cordero

    Guias de los Mount and Blade
    Spoiler:
    Soluciones a dudas y problemas.
    [Tienes que estar registrado y conectado para ver este vínculo]
    Guía Maestra para Mount& Blade: Todo lo que debes saber
    [Tienes que estar registrado y conectado para ver este vínculo]

    Guias en general [Tienes que estar registrado y conectado para ver este vínculo]
    avatar
    elgranselda
    Espadachín
    Espadachín

    Mensajes : 276

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por elgranselda el Jue Nov 07, 2013 2:58 am

    Eres sabio, Maestro :adorar: 

    estoy en ello, me dio error al principio pero reinstalare el juego porque hice muchos cambios anteriormente.

    te aviso cuando termine Very Happy

    editado: me esta presentando un error ahora al cargar el juego y el morgh's, como dijiste el item me aparece en lo ultimo del programa;



    pero cuando selecciono el item me aparece esta ventana y noto estos cambios;
    1:el error claro Razz 
    2:los atributos no estan o estan diferente, como de tipo arma
    3:el nombre del item es otro( como una especia de espada Suspect )



    Última edición por elgranselda el Jue Nov 07, 2013 3:42 am, editado 1 vez


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]




    La verdad nos hara libres study
    avatar
    Neodrako
    Usuario VIP
    Usuario VIP

    Mensajes : 4408
    Edad : 34
    Facción : Gran Polonia

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Neodrako el Jue Nov 07, 2013 3:13 am

    Tienes que copiar todo lo que traiga esa línea del archivo item_kinds  y pegarlo al final del archivo item_kinds  del mod al que quieres llevar ese item pero tienes que pegarlo perfecto

    fíjate es esto

    en la línea de encima si hay un espacio antes de comenzar la línea.

    o si el ultimo numero esta desplazado hacia la izquierda. usa de referencia la línea de arriba para que al pegar esta la colocación sea la correcta. una línea colocada en el lugar correcto puede dar error por algo tan tonto como no dejar un espacio o añadirlo.

    bueno eso dara error incluso al entrar en el editor de ítems del Morghs, el Morghs es un chivato jejeje y si la línea es problemática lo dira sin dudarlo xd

    si sacas una foto una ves que pegues la línea mejor a si puedo ver la colocación con respecto a la línea que tenga encima


    _________________
    Prefiero vivir un dia como lechón que 100 años como cordero

    Guias de los Mount and Blade
    Spoiler:
    Soluciones a dudas y problemas.
    [Tienes que estar registrado y conectado para ver este vínculo]
    Guía Maestra para Mount& Blade: Todo lo que debes saber
    [Tienes que estar registrado y conectado para ver este vínculo]

    Guias en general [Tienes que estar registrado y conectado para ver este vínculo]
    avatar
    elgranselda
    Espadachín
    Espadachín

    Mensajes : 276

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por elgranselda el Jue Nov 07, 2013 4:25 am

    Ok asi es como lo hago





    despues voy a itemskids del mod que tiene mi item (tan dolorosamente preciado)





    ahora voy a itemskids del mod que quiero jugar bounce 



    lo pegue en lo ultimo


    una cosa rara de la que me fije fue esto





    lo raro es que en la lista de modelos el black_2 aparece en material como black, pasa lo mismo con el otro, lo digo porque pueda ser el origen del error nose Neutral


    Edit: encontre el error load_mod_resource
    tenia que ser asi load_module_resource gracias por la ayuda de hijodeleon pude encontrar el error
    pero claro esta, por la ayuda del grandisimo Neodrako Very Happy 

    Lo malo es que el casco me aparece sin colo puramente en blanco. Alguna idea?


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]




    La verdad nos hara libres study
    avatar
    Neodrako
    Usuario VIP
    Usuario VIP

    Mensajes : 4408
    Edad : 34
    Facción : Gran Polonia

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Neodrako el Jue Nov 07, 2013 10:19 am

    No ese no es el error. el error es un espacio.

    y load_module_resource es solo para el modulo principal osea el original y  load_mod_resource  es para tus propios modulos incluso hay una descricion de eso en ingles en el propio archivo.

    yo vi tu error en el archivo  item_kinds   y si te fijas en la línea de encima ves que antes de itn hay un espacio pero en la línea que pegaste no dejaste ese espacio y solo por eso ya tira error.

    luego veo que el casco no refleja las texturas

    mira esto lo copie del propio archivo module ini.



    #You can also use load_mod_resource instead of load_resource to make sure you are reading files from module directory.

    load_resource = test
    #load_resource = textures_face_gen #quitado chief
    load_module_resource = textures_face_gen #puesto chief
    load_resource = shaders
    load_resource = textures
    load_resource = materials
    #load_resource = materials_face_gen #quitado chief
    load_module_resource = materials_face_gen  #puesto chief
    load_mod_resource = lundic_weaponry
    load_mod_resource = viking_hachela

    mira que dice en ingles arriba y además como lo tengo yo.

    si usas load_module_resource  funciona pero entonces estas creando mas de un modulo principal y eso debería ser exclusivo del mod.

    y tus añadidos deberían figurar como eso como un añadido  load_mod_resource

    ¿las texturas ? no le veo texturas a tu casco

    tienes que buscar sus texturas y ponerlas en la carpeta texturas del mod

    edito: Mike hazme un favor se que hay tutoriales donde dicen usar esto. load_mod_resource = en el module ini y no es que no sirva usar load_module_resource = pero eso antiguamente se conocía como intrusismo.

    el load_module_resource = es para el brf principal de un mod o del native y ami quien me enseño en persona me enseño que usara load_mod_resource = y en tutoriales de este foro lo evisto también pero no termino de encontrarlo.

    un profesional solo usa Ms y nunca usa métodos instrusivos ejemplo mark7. por otro lado yo aprendi del guanche mi primo crador de un tipo de flechas de fuego y colaborador del mod la conquista de canarias. pero como hasta hace nada tenia olvidadas sus enseñanzas cree mi pack del 1257 con Morghs y funciono si no digo que no. pero los profesionales no es mi caso usan solo ms y el resultado es una implantación que el juego reconoce como propia nada intrusiva asi me enseñaron hace años a mi y aunque no mantuve ese conocimiento lo estoy recuperando y quiero que los usuarios sepan mas que yo ya que estoy muy comodo en mi grata ignorancia. si lo que afirmo es verdad y creo que hay tutoriales en este foro que lo afirman please Mike muéstralo o quítame la razón pero lo nuevo se pone en module ini como load_mod_resource ya que dejamos load_module_resource = para el brf principal de un mod o del natve. dicho sea que en mods de conversión total ese modulo es el de los creadores.

    pero en modificaciones personales de poco impacto como mi pack del 1257 lo ideal es load_mod_resource = ya que mi modulo ni es el principal ni lo pretende pero cumple igual.


    _________________
    Prefiero vivir un dia como lechón que 100 años como cordero

    Guias de los Mount and Blade
    Spoiler:
    Soluciones a dudas y problemas.
    [Tienes que estar registrado y conectado para ver este vínculo]
    Guía Maestra para Mount& Blade: Todo lo que debes saber
    [Tienes que estar registrado y conectado para ver este vínculo]

    Guias en general [Tienes que estar registrado y conectado para ver este vínculo]
    avatar
    Sergivs5
    Hombre de armas
    Hombre de armas

    Mensajes : 923
    Edad : 18
    Facción : Rhodok

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Sergivs5 el Jue Nov 07, 2013 3:45 pm

    Pongo esto de un tutorial hecho por Sowort [Tienes que estar registrado y conectado para ver este vínculo]

    Spoiler:
    5) una vez copiado todo en sus respectivas carpetas, devemos ir al archivo Module.ini de la carpeta Native/mod que quieran y modificarlo

    vayan a la linea que dice:
    load_resource = materials_face_gen

    y debajo de esta escriben:
    load_mod_resource = "el recurso .brf de el OSP"

    en este caso el recurso se llama: "Rus_armour_pack"
    lo que quedaria asi:
    load_mod_resource = Rus_armour_pack


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]
    avatar
    Neodrako
    Usuario VIP
    Usuario VIP

    Mensajes : 4408
    Edad : 34
    Facción : Gran Polonia

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Neodrako el Jue Nov 07, 2013 4:38 pm

    Muchas gracias Sergivs5 una imagen vale mas que mil palabras tienes +1 de rep por las molestias


    _________________
    Prefiero vivir un dia como lechón que 100 años como cordero

    Guias de los Mount and Blade
    Spoiler:
    Soluciones a dudas y problemas.
    [Tienes que estar registrado y conectado para ver este vínculo]
    Guía Maestra para Mount& Blade: Todo lo que debes saber
    [Tienes que estar registrado y conectado para ver este vínculo]

    Guias en general [Tienes que estar registrado y conectado para ver este vínculo]
    avatar
    Sir Centu
    Moderador
    Moderador

    : : Peer forward with your head high
    Mensajes : 4487
    Facción : Corte Real de Boletaria

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Sir Centu el Vie Nov 08, 2013 3:16 pm

    No sé como se ha pasado esto.

    Selda, es el segundo doble-post que te veo hacer, te voy a dar una oportunidad antes de ponerte un aviso. Repito: No hagas doble-post, edita los mensajes en su lugar.


    _________________
    [Tienes que estar registrado y conectado para ver este vínculo]
    [Tienes que estar registrado y conectado para ver este vínculo]

    Contenido patrocinado

    Re: Problemas para añadir items; No los veo en el partida

    Mensaje por Contenido patrocinado


      Fecha y hora actual: Mar Nov 21, 2017 1:55 am